CVE-2018-19290


11/30/2018

CVE-2018-19290

In modules/HELPBOT_MODULE in Budabot 0.6 through 4.0, lax syntax validation allows remote attackers to perform a command injection attack against the PHP daemon with a crafted command, resulting in a denial of service or possibly unspecified other impact, as demonstrated by the “!calc 5 x 5” command. In versions before 3.0, modules/HELPBOT_MODULE/calc.php has the vulnerable code; in 3.0 and above, modules/HELPBOT_MODULE/HelpbotController.class.php has the vulnerable code.

References: 



Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *