CVE-2018-20345


12/21/2018

CVE-2018-20345

Incorrect access control in StackStorm API (st2api) in StackStorm before 2.9.2 and 2.10.x before 2.10.1 allows an attacker (who has a StackStorm account and is authenticated against the StackStorm API) to retrieve datastore items for other users by utilizing the /v1/keys “?scope=all” and “?user=” query filter parameters. Enterprise editions with RBAC enabled are not affected.

References: 
https://stackstorm.com/2018/12/20/stackstorm-v2-9-2-and-v2-10-1-a-security-release/



Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *