CVE-2019-7722


02/11/2019

CVE-2019-7722

PMD 5.8.1 and earlier processes XML external entities in ruleset files it parses as part of the analysis process, allowing attackers tampering it (either by direct modification or MITM attacks when using remote rulesets) to perform information disclosure, denial of service, or request forgery attacks. (PMD 6.x is unaffected because of a 2017-09-15 change.)

References: 
https://github.com/pmd/pmd/issues/1650



Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *