CVE-2019-8985


02/21/2019

CVE-2019-8985

On Netis WF2880 and WF2411 2.1.36123 devices, there is a stack-based buffer overflow that does not require authentication. This can cause denial of service (device restart) or remote code execution. This vulnerability can be triggered by a GET request with a long HTTP “Authorization: Basic” header that is mishandled by user_auth->user_ok in /bin/boa.

References: 
https://github.com/WhooAmii/whooamii.github.io/blob/master/2018/netis/buffer%20overflow.md



Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *