Flaws in Popup Builder Plugin Impacted Over 100,000 WordPress Sites


More than 100,000 WordPress websites were potentially affected by a series of vulnerabilities recently discovered and addressed in the Popup Builder plugin.

Designed to help with the creation and management of promotional modal pop-ups for WordPress blogs and websites, Popup Builder also includes the ability to run custom JavaScript code when the pop-up is loaded.

Security researchers at WordPress security firm Defiant report that Popup Builder before version 3.64.1 is impacted by vulnerabilities that could allow attackers to inject malicious code without authentication, or leak user information and system configuration data.

The most important of the vulnerabilities is a high-severity stored cross-site scripting (XSS) bug tracked as CVE-2020-10196 and featuring a CVSS score of 8.3.

The security flaw could be exploited by an unauthenticated attacker to inject malicious JavaScript code into any pop-up, thus having it executed when the pop-up is loaded.

The plugin registered an AJAX hook intended to allow auto-saving of draft pop-ups, but the hook was found to be exposed to unprivileged users. Moreover, the function called by the hook did not include nonce checks or capability checks.

Because of that, an attacker could send a POST request to wp-admin/admin-ajax.php with a malicious JavaScript payload, which would result in the payload being saved to the pop-up’s settings and executed whenever the pop-up is displayed on a page.

While such vulnerabilities are typically abused to redirect users to malvertising sites or for information theft, the issue could also be leveraged for site takeover if the infected pop-up was displayed to a logged-in administrator, Defiant says.

Another issue addressed in the plugin this week is CVE-2020-10195 (CVSS score 6.3), which could allow a low-privileged authenticated user to export a list of all newsletter subscribers and system configuration details, or even grant themselves access to features of the plugin.

The vulnerabilities were reported to the plugin’s developer on March 5, with a fully patched version of Popup Builder (version 3.64.1) released on March 11.

“While we have not detected any malicious activity targeting Popup Builder, the stored XSS vulnerability can have a serious impact on site visitors and potentially even allow site takeover,” Defiant underlines.

Related: Patches Released for WordPress Plugin Vulnerabilities Exploited in Attacks

Related: WordPress Websites Hacked via Vulnerabilities in Two Themes Plugins

Related: Flaw in WordPress Themes Plugin Allowed Hackers to Become Site Admin

view counter

Ionut Arghire is an international correspondent for SecurityWeek.

Previous Columns by Ionut Arghire:
Tags:

Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *