Several Vulnerabilities Patched With Release of WordPress 5.4.1


Several vulnerabilities, most of which have been described as cross-site scripting (XSS) flaws, have been patched in WordPress this week with the release of version 5.4.1.

WordPress 5.4.1, described as a short-cycle security and maintenance release, fixes 17 bugs and 7 vulnerabilities affecting version 5.4 and earlier. WordPress developers pointed out that all versions newer than 3.7 have been updated as well.

WordPress security firm Defiant has published a blog post describing each of the patched vulnerabilities and none of them appears too serious or easy to exploit.

One of the vulnerabilities is related to failure to properly invalidate password reset tokens. Specifically, password reset links sent via email would remain valid if the user manually changed their password from their account without using the link. However, in order to exploit this, an attacker would need access to the victim’s email account and the password reset link still needs to be valid.

Another flaw allowed an unauthenticated attacker to view private posts by making date and time-based queries. However, they would need to know the exact time — down to the second — of the targeted protected post.

The rest of the vulnerabilities have been described as XSS issues affecting the Customizer, Search Block, Object Cache, and file upload components. However, exploiting them requires authentication or access to the targeted system, which means they could only be useful to malicious actors when combined with other vulnerabilities or attacks (e.g. phishing a user’s credentials).

WordPress developers mentioned that the block editor was also affected by an XSS flaw that could have been exploited by an authenticated attacker. However, this issue was identified and fixed in release candidates and never made it into a stable release.

In the case of WordPress sites that support automatic updates, they should already be updated to version 5.4.1. Other users have been advised to download the latest version from the official WordPress website or from their dashboard.

WordPress websites continue to be highly targeted by malicious actors so it’s important that users install the latest updates. However, a majority of attacks exploit vulnerabilities in plugins and themes rather than the WordPress core.

Related: Flaw in WordPress Themes Plugin Allowed Hackers to Become Site Admin

Related: Unpatched Flaw in Discontinued Plugin Exposes WordPress Sites to Attacks

Related: Critical Flaw in SEO Plugin Exposed Many WordPress Sites to Attacks

view counter

Eduard Kovacs (@EduardKovacs) is a contributing editor at SecurityWeek. He worked as a high school IT teacher for two years before starting a career in journalism as Softpedia’s security news reporter. Eduard holds a bachelor’s degree in industrial informatics and a master’s degree in computer techniques applied in electrical engineering.

Previous Columns by Eduard Kovacs:
Tags:



Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *