Critical WooCommerce Vulnerability Targeted Hours After Patch


Hackers have started targeting a critical WooCommerce vulnerability only days after patches started rolling out, patchstack says.

WooCommerce is a popular open-source eCommerce plugin for WordPress, with more than 5 million installations to date, making it an attractive target for cybercriminals.

On Thursday, WooCommerce said that on July 13 it received a report of a critical vulnerability in the plugin, urging users to update their installations as soon as possible, but without providing additional information on the bug itself.

“Upon learning about the issue, our team immediately conducted a thorough investigation, audited all related codebases, and created a patch fix for every impacted version (90+ releases) which was deployed automatically to vulnerable stores,” the WooCommerce team said.

The team revealed that WooCommerce versions 3.3 to 5.5 and the WooCommerce Blocks feature plugin versions 2.5 to 5.5 were found to be impacted, explaining that version 5.5.1, “or the highest number possible in your release branch,” address the issue.

According to patchstack, the vulnerability is an SQL injection bug that is already being targeted in a limited set of attacks. The targeting started on the evening of July 15.

“These attacks seem to be very limited so far, but seem to be using UNION and SLEEP based SQL injections,” patchstack said. The website protection firm also published a set of indicators of compromise.

Site admins are advised to update their WooCommerce installations as soon as possible to ensure that both their websites and their users remain protected.

“The discovery of a new SQL injection (SQLi) vulnerability in WooCommerce is a good reminder to check on the security and to update programs used with WordPress (in addition to checking on and updating WordPress itself). SQLi vulnerabilities are part of the OWASP Top 10 Web Application Risks, and well known, so it’s a surprise these vulnerabilities aren’t discovered during application development,” Pravin Madhani, CEO and Co-Founder, K2 Cyber Security, told SecurityWeek in an emailed comment.

Related: Vulnerability That Allows Complete WordPress Site Takeover Exploited

Related: Hackers Exploiting Recent Vulnerabilities in Thrive Theme WordPress Plugins

Related: WordPress Malware Targets WooCommerce Stores

view counter

Ionut Arghire is an international correspondent for SecurityWeek.

Previous Columns by Ionut Arghire:
Tags:

Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *