Cisco Patches Critical Vulnerability in RCM for StarOS


Cisco on Tuesday announced patches for a critical vulnerability in the Redundancy Configuration Manager (RCM) for the StarOS software running on its ASR 5000 networking devices.

A Cisco proprietary node/network function, RCM delivers redundancy of StarOS-based user plane functions.

Tracked as CVE-2022-20649, the newly addressed critical vulnerability (CVSS score of 9.0) could be exploited remotely, without authentication, to execute code “with root-level privileges in the context of the configured container.”

On specific services, the debug mode hasn’t been correctly enabled, thus allowing an attacker to connect to the device and navigate to such a service to exploit the vulnerability.

“The attacker would need to perform detailed reconnaissance to allow for unauthenticated access. The vulnerability can also be exploited by an authenticated attacker,” Cisco explains in an advisory.

The patch for CVE-2022-20649 also addresses a medium-severity issue (CVE-2022-20648) that could allow a remote, unauthenticated attacker to leak confidential information. The flaw exists because a debug service doesn’t correctly filter incoming connections.

Both security defects were resolved with the release of RCM version 21.25.4. Cisco encourages all customers still using an RCM release prior to 21.25 to migrate to a fixed version.

On Tuesday, Cisco also announced the availability of patches for high-severity vulnerabilities in the Modbus preprocessor of the Snort detection engine and in the implementation of the CLI for multiple Cisco products.

Tracked as CVE-2022-20685 (CVSS score of 7.5), the first of the bugs is a buffer overflow that could allow a remote, unauthenticated attacker to cause a denial of service (DoS) condition by sending crafted Modbus traffic through an affected device.

Cisco announced the availability of software updates to address the vulnerability in multiple products, including FTD, Cybervision, Meraki MX, UTD, and Snort.

Affecting the implementation of the CLI on various products and tracked as CVE-2022-20655 (CVSS score of 8.8), the second high-severity issue is described as an insufficient validation of a process argument.

An attacker could exploit the flaw to inject commands that would be executed with the privilege level of the management framework process, which usually runs as root.

Cisco published two advisories for this vulnerability, one detailing patches for the ConfD on-device management framework, and another dealing with the fixes released for various networking devices.

The tech giant says it is not aware of any of these vulnerabilities being exploited in malicious attacks.

Related: Cisco Patches Critical Vulnerability in Contact Center Products

Related: Cisco Plugs Critical Holes in Catalyst PON Enterprise Switches

Related: Cisco Patches High-Severity Vulnerabilities in Security Appliances, Business Switches

view counter

Ionut Arghire is an international correspondent for SecurityWeek.

Previous Columns by Ionut Arghire:
Tags:

Don't forget to share

You may also like...

Leave a Reply

Your email address will not be published.